OpenWrtにNordVPNをインストール


WordPressの処理をVR-500に任せてWXR-2533DHPが身軽になったので、VPNクライアントとして活用します。

luci上では、Insufficient permissions to read UCI configuration.
のエラーがでるのでluci-app-openvpnをいれないでセットアップしました。

opkg update && opkg install openvpn-openssl ip-full

NordVPN公式から任意のUDPファイルをダウンロードして
/etc/openvpn/***.nordvpn.com.udp.ovpnへコピーしますが、編集が必要です。そのままでは動作しないので注意して下さい。

vi /etc/openvpn/***.nordvpn.com.udp.ovpn 次の行を加えます。

auth-user-pass /etc/openvpn/nordvpn.auth

vi /etc/openvpn/nordvpn.auth ログイン情報を加えます

ID
パスワード

セキュリティのため、権限を変更します。

chmod 600 /etc/openvpn/nordvpn.auth

openvpnの設定をします。

uci set openvpn.***udp=openvpn
uci set openvpn.***udp.config='/etc/openvpn/***.nordvpn.com.udp.ovpn'
uci set openvpn.***udp.enabled='1'
uci commit openvpn

cat /etc/config/openvpn 以下の用になっていればOK

config openvpn '***udp'
option config '/etc/openvpn/***.nordvpn.com.udp.ovpn'
option enabled '1'

NORDVPNのDNSに変更します。

uci set network.wan.dns='103.86.96.100'
uci add_list network.wan.dns='103.86.99.100'

tun0を追加します。

uci set network.tun0=interface
uci set network.tun0.proto='none'
uci set network.tun0.ifname='tun0'
uci set network.tun0.delegate='0'
uci commit network

HGWのDHCPは無効にしているのでwan側のIPは固定しています。
cat /etc/config/network

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        list dns '103.86.96.100'
        list dns '103.86.99.100'

config interface 'tun0'
        option proto 'none'
        option ifname 'tun0'
        option delegate '0'

firewallの設定をします。

uci set firewall.@zone[0].device='tun0'
uci set firewall.@zone[0].family='ipv4'
uci set firewall.@zone[1].network='wan wan6 tun0'
uci commit firewall

cat /etc/config/firewall

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list device 'tun0'
        option family 'ipv4'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 tun0'

NordVPN公式にアクセスして上部に保護済みと出ることが確認できます。

海外で日本のnetflixが視聴できるようになります。

Daznは DAZN ISN’T AVAILABLE IN THIS COUNTRYと表示されます。日本リージョンを選択しても海外判定されるようです。

スマホでは10-000-000のエラーコードが出ますが、Playstoreのアプリからでは接続できました。

UDPではなく、TCP接続からでも同じだったのでもっと検証が必要です。

DNSリークテストのExtendestestを実行してDNSリークがないか確認したところ。
IPV6を使用しているとDNSが漏れるので停止したところDAZNも視聴できるようになりました。

OpenWrt

Posted by taroumaru